うちの こぁ i7機が。

久々に電源入れたら、まぁーたピィピィ言いだして、メモリ全部外して刺し直したら復活したのだが、こやつもメモリに爆弾抱えているのだろうか。

いまメモリ爆安だし、いっそ全部交換するか?

いやそれ以前に、こぁi7機は維持すべきか廃棄すべきか、という論点もあるんだが。

大体にして今や我が家には こぁi7デスクトップ、こぁi5デスクトップ、こぁi7 VAIO Z…と こぁ が大増殖中だしなぁ。Airも こぁ2Duoという、小悪魔デスサイズを乗っけた観鈴ちん、というアレ気な機体だし(最後なんか違う)。

| | コメント (2) | トラックバック (0)

こぁ i7 PCの電源を交換。

我が家最強を誇る小悪魔、 こぁ i7 920マシン。半年ほど前に電源を抜いたまま放置していたところをパワー重視系の開発機として使うべく、1TBのHDDも追加してDebianにて復活させたのですが…。

マザーボードのリチウム電池が切れていたので交換した後、どーも調子が悪かったのです。

具体的には、

  • エラー音連続発振で起動しない
  • 起動するけどOSが一通り立ち上がった直後フリーズ
  • ふと気付くとフリーズ
  • 画面上にsyslog書き込みに失敗した旨のメッセージを出しつつ操作不能(操作のたびにsyslogに書こうとするのでシャットダウンもできず)

等々。状況的にBIOS周りを疑い、実際CMOSクリアをするとしばらくは調子が良いのでBIOSが飛びかかっているかな…と思っていたのです。

で、そろそろメモリなど適合部品も手に入りにくくなってきたし、いっそCPUとM/Bとメモリを売り払ってしまおうと思っていたのですが…。最後に改めてGoogle様に聞いてみたところ、電源の劣化ではないかと言うことに気付きましたさ。

実際、HDDを取り払った状態での12V電圧が11.795Vといった具合にすこーし低いのです。他のは一応定格超過しているのですが。

という事で、売り払う前にまずは電源交換を。別の こぁ i5機も電源を強化したかったところなので、電源ユニットが無駄になることはないであろうと。

購入したのは Huntkey パソコン用ATX電源500W BK-5000

お値段そこそこ、12Vが4ライン化されているのが少し安心?(よくわからない)

80Plusへの適合はしていませんが、まぁ24時間連続フル稼働させるもんではない予定なので、当面あまり関係は無いかと。連続稼働させる気になったら再交換しても良いかも。

M/B側への供給ケーブルは、電源ユニット直付けなので、不要なラインがあっても外せません。まぁまとまりが良いので、それほど邪魔とは思いませんけどね。ケーブル帯も数本付いてきます。

従来搭載しているのも500Wなので、ここは変更なし。実は こぁ i7機に最近安いメモリを増設してしまい、12GBメモリ機などと言う意味不明な化物化も考えてはいるのですが…(12GBメモリだとたぶん500Wぢゃ足りない)。

ま、その場合はこの500Wを こぁ i5機に積むので良し、と。

本日交換して電源チェックしたところ、HDD繋いでも12Vは定格超過。代わりに5Vがすこーし下回っているけど…だ、大丈夫かな?(汗)

現状4時間ほど連続運転させていますが、特に障害は出ていない様子。まぁこれで様子見ですかねー。


しかし古い電源ユニットはどうしたものか…。それほどシビアな用途で使わなければ、まだまだ使える…かな?

参考までに、搭載した Core i7 920機の構成:

  • Core i7 920
  • メモリDDR3 10600 2GB×3 (6GB)
  • HDD 50GB ×1 (OS用)
  • HDD 1TB×1 (大量データ用)
  • Matrox Milleunium II 8MB (当初はGeForce積んでいたのですが、調子が悪い時に省電力狙いで交換、そのまま)
  • 光学ドライブなし

いたって普通というか、たぶんCPUの割にしょぼい構成だと思うので、あんまり参考にはならないかも。特にグラフィックボードのチョイスが(笑)

でも、このグラフィックボードでもDebian lenny + LXDE だとちゃんと使えるンよ?

元々SSHログインで使う予定だったので、ビデオは「とりあえずコンソールが映れば良い」程度という判断。

ちなみに、当面の主用途はお仕事で関係する技術の予備研究/検証用にJava開発に使いまする。Javaはメモリを喰うので、安いVPSだと足りんのです。

| | コメント (0) | トラックバック (0)

弾幕はパワーであることをちょっと思い知った今日。

あたしはヤフオクで自作イラストをチェックしているので、メールで届いたアラートをまとめて開き、順番に見ていく作業パターンが多いです。

で、メール環境などをThinkPad Edgeに移した都合上、そちらでいつものように画面を5枚ほど開いたのですが…。

Firefoxが半フリーズした。
むしろ現在進行形でしてる。。

タブブラウザは便利なのですが、結局複数枚のブラウザウィンドウを開いているのと同じってことデスか…。しかもイラスト出品、画像データ大きいしね…。

なんかプロセスモニタでもFirefoxがうんうん唸ってるし、排気ファンは温い風を出しっぱなしだし。もはやタブ切り替えどころか、スクロールもままならず。

デスクトップは1年以上前から論理8CPUのCore i7だったから、この辺の限界点を忘れていたよ…。たぶん、「ぷちフリーズ」っていうのも、パワーを考えずに振り回していたのかもね(汗)

まぁ、だからといってCore i7ノートを買う気にはならんが。価格面よりもスペックと重量とバッテリー持続時間が辛すぎる。

| | コメント (0) | トラックバック (0)

そういえば新版Core i5が出ていますね。

まー、今回のウリは「GPU統合」だと思っているので、そもそもメイン魔神はグラフィックカード設置が基本のあたしとしては、その時点で眼中にないわけだけど。

しかし、なんでコア数は偶数なのにCPU型番は奇数なんだろう…。

そしてココログのカテゴリ名「Core i7」を変更できないものかと思う今日この頃<新しいカテゴリ名を付け直せばいいんぢゃ…

| | コメント (0) | トラックバック (0)

Core i5+Windows 7 Pro.(x64)導入。

ようやっと重い腰を上げる気になったようです>あたし

結局、Core i5機を新規構築し、そこにWindows 7 Pro.をインストール、現Core i7機と入れ替えていく方針にしました。

現Core i7機は…。この後Linuxのみの魔神にして、サーバ運用しようかな…というかサーバにしか用途が無いぞこの無駄にハイスペックな構成(汗)

Intel Boxed Core i5 i5-750 2.66GHz 8M LGA1156 BX80605I5750 (Amazon)
Amazon.co.jpにて購入。横浜のDOS/Vパラダイス、Sofmap、あまり期待できないビックパソコン館をチェックした結果、ここが一番安かった(数百円単位だけど)ので。
ASRock P55M Pro
横浜DOS/Vパラダイスにて購入。今回は初期投資を抑え気味、小型化も狙うので、マイクロATXです。買うの何年ぶりだろこの規格…。
しかしなんでこのM/B、どこでも通販に載っていないんだろう?
 PQI JAPAN DD31333-2G2D 240pin DDR3-1333(PC3-10600) 2GB 2枚組 ヒートスプレッダ付 (楽天市場)
メモリは4GBで、とりあえず。Core i7機は何かを思いたって6GB(2GB×3)が積み込まれていましたが、使うアプリが結局32bitタイプばかりなので、当面4GBもあれば良いだろう、と。
PALiT GeForce GT240 1GB (DDR3)
今回比較的重要視したところ(その割にコスト削減しているが)。いい加減グラフィックカードは新しくしたかったので。
やっぱり通販系に出てこない諏訪子カエルさんメーカー。
当初DDR5を導入する気だったのに、つい安いのを手に持ってしまってさっき気付いたらDDR3だった罠。
USB2.0拡張ボード(PCI)+Windows 7 Pro. x64
コレ以上USBを増やしてどうするのかとも思ったけど、USB3.0ボードは売り切れ、FDDはさらに買う気がしないので。
レイのイメージキャラの年賀状が付いてきましたが、ぶっちゃけいりません。まっしぐらにしてくださいよ、まっしぐらに(自分でやれ)。
SATA3拡張ボード(PCIe x1)
M/Bとセットで買えたので。まぁ使うこともあろうかな、と。
ミニタワーケース(エバーグリーン 電源ユニット TWG-AL625BL W/400w(ブラック) TWG-AL625BL400W)
電源450Wタイプ。まぁあまり予算をあてるところではないやね。

HDDは以前データドライブがクラッシュした時に購入していた、日立DeskStarの500GB SATAを転用。キーボードはみょんに使用率が高いミヨシ レーザー式トラックボール内蔵キーボード(ブラック) TK-24G04/BK(Amazon)。

光学ドライブはブルーレイを導入するか迷った末、今回は見送り。最終的には現Core i7機から移植する予定。インストールは外付けドライブでやってまする。

…とか書いているうちに、あっさりとWindows 7のインストールが終わったらしい。取り敢えずWindows updateを一通りやって、今日は終了かな。

ハードウェアの構築は、ほぼ問題なく。

主に2スロット専用のビデオカード積んだら、直下にあるPCIe x1のスロットがふさがってしまい、SATA3ボードが入らなくなった!という罠と、M/Bにある電源LEDコネクタが2ピン、HDD LEDコネクタが3ピンで、ケース側は電源LED3ピンとHDDLED2ピンだったという罠くらいか。

SATA3ボードはCrossFire幼に用意されているPCIe x4を使って対策、LEDは電源とHDDを入れ替えて対策…っと。

…ところで、ビデオカードのドライバは最新版を使用しようと思ってメーカーサイトからダウンロードしているのですが、光ファイバー回線で150MBを転送するのに残り1時間43分ってどうなのさ?(汗)

| | コメント (0) | トラックバック (0)

Windows 7 RCをCore i7機に入れてみる(割と本気)。

ベータの時点から、結構安定感があるので大丈夫だろうと思っていたのですが。

昨日、半ば発作的に実行へ。

パーティション切り直しが面倒なので、HDDは手頃な500GBを4980円で追加購入。

Windows 7は、64bit版を選択。メモリ6GB積みの威力を発揮させるべく。

インストール作業自体は何の苦もなくすいすい進んだので、特に書くべきこともなく。

敢えて言うなら、プロダクトキーをOutlookでメモした後HT-01Aに転送し忘れ、Vistaを起動しなおすのが面倒くさく、仕方がないのでOffice Pro.の試用版をダウンロードしてWindows 7にインストールし、そこからVista側に保存していたOutlookのデータファイルを開いてキーを取り出す、という>謎<行動に手間取ったくらい<馬鹿

あー、そういう意味では、Outlookは普通に動いていたような気がします。Windows 7上で。

で。
必須条件その一。Wacomの液晶タブレットは動くのか?

…64bit用Vistaドライバを入れてみたところ、軽く使う分には特に異常はない様子。いけるか?

必須条件その二。COMIC ART CG illust PLUSは動くのか?

…ふつーに4.5を入れてみたところ、液タブでざくざくと落書きする程度なら特に異常はない気が。いけるの?!

残るはプリンタとイメージスキャナだ。しかし、この2つは余剰ができたVistaをAtomコアに入れてネットワーク化するとかいう手もあるので、そんなに気にする必要はなさそう。

FirefoxとThunderbirdはまだ入れていないけど、これもなんなら他のマシンとか、VM上のLinuxとか、色々逃げ道はある。

グラフィックソフトと液タブは、ハイパワーマシンに繋げないと意味がない代物なので、この2つが動いた時点でほぼ障害はなくなった気がする。

ここは、本格的にWindows 7へ移行してしまおうかと画策中の今日この頃。

あ。
OutlookとHT-01AのAcitvesyncは試さないと。
しかし、これもぶっちゃけAtomコア+Vistaで「スケジューラ専用機」としても問題ないか…。

あとはエロゲーと東方Project御一行さまですな!
しかし、最近はすっかりキャスパーたんでお腹いっぱいなので、当面は困らないか?(笑)
てか、こいつらもAtomで十分動くか…。東方は、昔MURAMASAとかType Uとかでやってたし。

今のところ何も困っていないので、レイのウリ、XPモードは試してもいないわ…。

| | コメント (0) | トラックバック (1)

だめだこりゃ。

起動はするが、起動途中でグラフィカルモードに切り替わった途端、緑の縦線で画面が覆いつくされる。Matrixデスか?

辛抱して起動させてみるも、run levelが5のままなので、ログイン画面もやっぱり緑の縦線に。

起動時にGrubの設定を編集、run levelを3で起動すると、ちゃんと起動できた。

が、ログイン後startxしてみると、やっぱり同じ症状。ディスプレイドライバが逝かれたな、これは。

うーん、X-Windowの設定をやり直すか、試しにクリーンインストールしてみるか(そしてその時に今度こそWindows 7用領域を切るか)。どうしたものやら。

| | コメント (0) | トラックバック (0)

CentOS5.3のアップデートインストールをCore i7機に。

「Linux軽量化」の記事が気になって日経Linuxを買ったら、いつのまにかCentOSの5.3がリリースされていることに(雑誌に付いてきていることに)気づいたので、家のメインマシンに入れたものの、何故かいつの間にか起動不能になっていたCentOS 5.2をなんとかする気になった(軽量化の話はどうした)。

で、5.2のときはブートCD+内蔵DVDドライブで起動に失敗したり、ギガビットイーサの認識に失敗してネットワークが使用不能になったりと要らん苦労が多い組み合わせだったので、さすがに今回のバージョンアップではすっきり解決しているだろうと思ったのですが…。甘かったらしい?

インストールは、前回と同じくx86-64。雑誌付録はどうせ32bit版だろうと思ったので、ネットからDVDイメージをダウンロード。いちおう、フルセットとnetinstを。

フルセットは焼くのに時間がかかりそうで嫌だったので、netinstをDVDに焼き付け。ちなみに、この時は

  1. Windowsでダウンロード。
  2. Windows用のトーストソフトが無かったので、おもむろにVirtual Boxでdebianを起動。
  3. 仮想debianから、smbmountでWindowsディスクをマウント。
    $ sudo mount -t smbfs -o username=xxx,password=xxx //windows/share /mnt/share
  4. 仮想debianから、物理DVDドライブに入れたDVD-Rに焼き付け。X-Windowで、右クリック一発。8GBなので、まぁ数分でこんがりと。

…という、見事に挙動不審な行動をとってみたり。

そして、おもむろにWindowsを終了し、焼いたDVD-Rで起動!ネットワークメディアの選択で、FTPを選択!えぇっ?!URLなんて覚えてないよっ?!<リストが出てくるdebianと間違えていたオチ

とりあえず、予備機のAtom+CentOS機を起動、ネットで確認、転記。待つこと数分…。ふと気づくと、そこには一面のモザイクがっ(爆)

ウンともスンとも言わないので、とりあえずESC+CTRL+ALT+BackSpaceしてみる。…なんかキーが余計な気もするけど、まぁいいか。

案の定、X-Windowの起動に失敗したようなのだけど…。特にエラーメッセージが出ていないので、なんか原因不明。

トライ2。失敗した原因がネットワーク障害にある可能性があったので、netinstから本体を取ってくる場所を、インターネットからLANに切り替えてみる。

フルセットのISOイメージは、家庭内サーバとして起動していたdebian機で落としていたので、ここでHTTP公開することに。

ちなみに、この機体は光学ドライブを積んでいないので、さっきのDVD焼きには使えなかったのですな。そしてこいつから他のトースト可能マシンに転送する時間が鬱陶しかったので、焼き付けはしない方向で。

  1. 適当にディレクトリを掘る。
    $ sudo mkdir -p /var/www/Linux/centos/5.3
  2. ISOイメージをマウント。
    $ sudo mount -t iso9660 -o loop ~/share/CentOS-5.3-x86_64-bin-DVD.iso /var/www/Linux/centos/5.3
  3. HTTP経由で参照できることを確認。
  4. 確認したURLをインストーラに指定。

で、めでたく失敗(おぃ

トライ3。いい加減グラフィックインストールはあきらめ、テキストモード発動。DVD起動直後、linux textでGo!

…途中、VNCモードに気をとられて試すも、やはり失敗。うーん、どうもグラフィックインストールは絶望的か?ビデオカードが悪いのか?

トライ4で完全テキストインストール(英語)。途中、「既存のCentOSをアップグレードするか?」と聞かれたので、さっくりアップデートしてもらうことに。

そして今、インストール待ち。30分経過で、94%完了。無事に起動すると良いのだけどねぇ…。

…あ。
今回のインストール時に、Windows 7RC用の領域を切り直せば良かった!<馬鹿

そうこうしているうちに、インストールは終わったらしい…が、ゲージが100%になったのに画面が進まないって言うのは…。失敗?(汗)

#ぬわ。タイトルが「5.3]ではなくて「3.5」になってた…(汗)

| | コメント (0) | トラックバック (1)

LCD-8000Uが何か微妙な。

障害切り分けが完ぺきではないのですが。

LCD-8000Uをつないだ状態でShade 8.5 Basicを起動すると、9割がたブルースクリーンになってWindows Vistaがクラッシュします。

インストール当初問題がなくて、心当たりはそれだけだったので、試しに外してみると、正常起動できるのですな。

ただ、正常起動した後でLCD-8000Uを繋いでも異常はなく、その状態でShadeを終了→起動しても、これまた異常なし。

こいつかなー、別の要因(Core i7かメモリ多すぎ)かなー、しかし青画面は久しぶりに見るなー、と思っていたのですが。

昨日買ってきたPoser 7(買ってしまった…)をインストールしたところ、同じ現象がっ!

しかもこっちは、初回起動の登録時に落ちるため、3回連続でシリアル番号を打ち込む羽目に…(汗)

どちらも3Dシステムなので、画面構成周りでトラブルが出ても不思議はないだろうと思いますが…。うちでLCD-8000Uの使用、止めたほうが良いのかも。

メーカーサイトにもドライバアップデートは出ていないみたいだし…。

あと。
異常が出たりその他の理由でこいつを一時的に外したいとき、ドライバソフトのDisplayLinkで「無効」を選択、その後外しているのですが…。

無効にすると、タスクバーやサイドバーが透明化する現象が。

特に深刻なのがタスクバーで、Windowsボタンは表示されるので最低限のことはできるものの、クイック起動やインジゲータ部分、起動中アプリのアイコンも透明化してしまうため、アプリの起動に困る。

何よりも、DisplayLinkへの再アクセスに非常に困る(汗)

一度、タスクバーの位置を縦→横などのように移動させれば、復帰するようではあるのですが…。

動きがチョー微妙な感じですわね…。

| | コメント (0) | トラックバック (0)

Core i7機に入れたCentOSが起動しなくなった。

最近めっきり起動していなかったんだけど、ちょっと思いついたことがあっていじろうとしたら。

起動途中で「Memory for crash kernel (0x0 to 0x8) notwithin permissible range」が出た後、いくら待っても先に進まない…。このメッセージ自体は無視できる、と公式サイトにもあるようなのだけど、無視しようにも起動しないんでは…(汗)

おかしいなー。起動していないゆえ、本気で全く何もしていないんだけどなぁ。

その間にWindows 7betaのインストーラ起動したとか、ほかのLinuxを起動したとかやったとき、どこかが書き変わった、とでも?

仕方ないので再インストールしよう…と思ったのだけど、こちらはなぜかHDDのマウントあたりで止まる…?

KNOPPIXも途中で止まるし、巫女ぐにょは起動するけどなぜかHDDが見えないし。

その後諦めて普通にWindows Vista起動したら、こんどはこっちでオンボードのLANが認識しなくなるし。

なぜかBIOSでも認識しない(ケーブルチェックが発動しない)状態になるし。

電源を完全に引っこ抜いてから起動したら、LANのほうは回復した。…が、Linuxは未だ起動せず。むむぅ。

ちなみに何をやろうかと思ったかというと。

CentOSは64bit版を入れているので、メモリリソースを6GBフルに使えているのですよ。
なので、この上でならSunのVirtual Box x64も動くだろうし、その上でならWindows 7 x64も動くだろうと。

この環境でWindows 7 x64が十分に(ゲームとかも)動くようなら、普段使いをCentOS+VMでWindows、にしても良いかな、と。そういうことを企んだわけで。

…はっ!!
まさかWindows離れを嫌気したゲイツの陰謀?!(笑)

| | コメント (0) | トラックバック (0)

たとえばクラスタを組むとしたら。

  • Core i7+メモリいっぱい+1物理ノードあたりのスレッド数多め

  • Atom N330あたり+メモリめいっぱい(=2GB)+1物理ノードあたりのスレッドは1本

どっちがいいですかねぇ。

前者は、M/B+CPU+メモリ6GBで、8万円台。ケースと良い電源積んで10万は行くか。グラフィックボードはセットアップ用に1枚くらいは必要か。

後者は、M/B(CPU付き)+メモリ2GBで、下手をすると1万円未満。ケースは小型化にこだわらなければ安いのがあるし、電源に凝っても2万円とかで何とかなりそうだよね。グラフィックは内臓なのでボード不要。

HDDはクラスタノードだったら500MB500GBの単発5,000円とかで充分。一時使用だし、あんまり大きなデータは使わない(転送に時間かかりすぎてクラスタの意味がない)し。

いや、たとえば会社に要求するとしたらどっちかなー、とか。

まぁまず通らないけど。どちらも。今Core2ノート×3台がレンタルで来てるだけでもラッキーだし。

Atom N330のMini-ITXマザーを大量にブレード実装して、信頼性の高いTBクラスのネットワークディスク装置をギガビットLANで繋いだクラスタシステム、とかいうのが、大学とかで流行りそうな予感。

| | コメント (0) | トラックバック (0)

うぐぅ。

嬉々としてVirtualBox 2.1をインストールし、新しいVMでCentOS 64bit版をインストールしようとしたら…。

Your CPU does not support long mode. Use a 32bit distribution.

ログを見ると、リアルCPUはちゃんとVirtual Machine Technologyが検出されているっぽい。もちろんVT-x/AMD-VはOnに。
あと、BIOSも確認してちゃんとEnableになっているのは確認したさ。

しかし、セッション情報を見るとランタイムが「VT-x/AMD-V=無効」
これはどういう意味なんだろう??VMのCPUがVT-x未対応…という意味ではないよねぇ???

うーむ。いったい何の設定が足りていないのやら。

| | コメント (1) | トラックバック (0)

Sun xVM VirtualBox v2.1。

OpenGLやIntel Core i7に対応した「Sun xVM VirtualBox」v2.1が公開 (窓の杜)

  • 本ソフトを実行する“ホストOS”が32ビットの場合でも、仮想PC上で動作させる“ゲストOS”として64ビットOSを利用できる
  • ハードウェアによる仮想化のサポートにおいて、Intelの新CPU“Core i7”のEPT/VPID機能に対応した。
  • ゲストOSが32ビット版のWindows XP/Vistaの場合に限り、OpenGLによる3Dアクセラレーションが可能。

これはつまり、アレですね?イけ、ということですね?

なにせ、あたしがVMWare Workstationをいつ買おうか、LinuxとWindows、どっちをホストにしようかと悩んでいたのは、この「ホストが32bitでも64bit OSを使える」という点だからね!
それ以外は、VMWare Playerで十分だったわけだし!

これは、さっそくインストールしてみるしか!

| | コメント (0) | トラックバック (1)

タイトルを忘れていることに気づいたけど今さら考えるのもめんどい。

この間Core i7マシンにCentOS 5.2 x64をインストールしようとして、全部入りDVD焼いたはずなのに早々に「ディスクイメージがない」と言い出したのは、やっぱりドライバ周りに何かある気配が。

今日、AtomマザーのほうにUSB DVDドライブ繋いでインストール試してみたら、同じCDであっさり完了するでやんの。

新しいチップセットだからなー。IDE接続周りすら、問題を抱えているんだろうか…。

とりあえず、Atomマザーのほうにはインストールできたので、こっちでネットワークドライバコンパイルすれば、なんとかなるだろう…。

んで、できればPXEブート用のキット作成にでも挑戦してみるか…。

| | コメント (1) | トラックバック (0)

LANに繋がないとLANに繋げません >謎<

外付けHDD経由でディスクイメージを持ち込んだら、インストールはすんなり終わったんだけど。

起動時にはやっぱりLANを切っておかないとパニくる。

LANドライバを外付けHDD経由でソース持って行ってコンパイルしようとしたら、コンパイラが入っていないオチ(爆)

コンパイラのバイナリ、どこかにないかなーとgoogleに投げてみたが、どいつもこいつもyumでのインストールメモばかりが引っ掛かってくるので。

LANを動かしたいのにLAN経由でないと必要物資が取れないという素晴らしい袋小路が待っておりましたさ?(笑)

とりあえずー。
やっぱりインストールチェックまで終わらせて放置しているDual Core Atomのほうでバイナリ作るか…。無事に持って行ければいいけど。

あぁ。
インストールにあたって完全に盲点になっていた、「そもそも外付けSATAをインストール時にマウントできるのか?」という問題は、先のUSB変換アダプタがあっさり/dev/sdaになったので。

…なんかgrubがトチったらしく、BIOSでOSの入ったHDDを第1優先にしないと起動できない、という謎仕様が付いたけど。
きっとgrubの設定書き直せばいいんだと思うけど。

| | コメント (0) | トラックバック (0)

とりあえず、SATA→USBなアダプタ。

とりあえず、GroovyのUD-505SAを購入。ビックカメラで\1880。


SATA-USB2.0変換アダプタケーブルGroovy UD-505SA
【超パソコン専門店】グッドウィル

こいつのIDE→USB版を持っているのと、箱の説明書きにACアダプタからSATA HDDにつなぐまでの間に1個アダプタを挟むという謎構造にちょっと思うところあって決定。

帰宅後開けてみると、案の定ACアダプタから伸びているのは4ピンコネクタ、そこから変換ケーブルでSATA電源。
これでアダプタは共有できるわけで。よしよし。

…とか言いつつ、さっきまでなんとかしてinitrdにLANのドライバ入れちゃおうと思ってごそごそやっていたのだけど…。
Realtekから落としてきたのがソースコードで、起動しているLinuxが32bitのdebianで、欲しいのは64bitドライバってあたりで鬱になり、とりあえずやってみよー、とmake始めたもののエラーになったあたりで嫌になった。

いいんだもん。あたしサーバ管理者目指してないもん。なんか最近来る仕事、クラスタシステム構築ネタばっかりな気がするけど…(汗)

そして、余剰のSATAディスクにインストールイメージをコピーするにあたり、このHDDをどうやってext3フォーマットするのか?という現実に気づくあたり。

…とりあえずDebianサーバにつないでみたら、あっさり/dev/sdaにくっついてくれたけど。やれやれだ。

つーことで現在、HDDにイメージをコピー中…とか書いていたら終わった。

| | コメント (0) | トラックバック (0)

なんか袋小路。

Core i7機へのCentOSインストール。DVDイメージを焼いて起動しても、途中でパニックに。

改めてよーっく見ると、traceのトップがどうもLANのチップ名。
インストーライメージが、LANデバイスの認識に失敗している…ってあたりか。Dual Core Atomのときと同じやね。

オンボードのLANをBIOSでdisableにしてみると、インストーラは起動した。なぜかテキストモードだけど。

が。
CD-ROM(正確にはDVDだが)にCentOSのディスクイメージが無い、とおっしゃる。ちゃんと全部入りのDVD入れているんだけど…?

それとも、これも何かドライバ問題が???
ブートローダーについては、Linux内のドライバは、関係無いものね…。

で。
HDDに元のディスクイメージが残っているはずなので、それを指定。…見つからない、と言い張る。

よくよくログを見ると、ext3やらFAT32やらを探し回っていた模様。そこはNTFSだよ…。

FTPもNFSもHTTPも、LANデバイスを殺しちゃったので使えず(汗)

いったんWindowsを起動し、FATフォーマットな8GBのUSBメモリにディスクイメージをコピーしてやれば良いかと思いきや、FAT32では4GBのファイルは扱えません、と(瀧汗)

余っているHDDをext3でフォーマットしてイメージ入れてしまえ、と思ったけど、余りのHDDはSATA。うちにはIDE→USBのケーブルはあるけど、SATAのは無い。

SATAのHDDをIDEにつなぐためのケーブルはあったので、これでSATA→IDE→USBという謎行動をとろうと思ったところ…。SATA→IDEケーブルのIDE口がメスピンで、IDE→USBのケーブルもメスピンというオチが。ジェンダーチェンジャーは無いな、さすがに。

とりあえず…。
明日SATA→USBのケーブルを買ってきて、あと素直にケース開けて予備のPCI LANカード刺すとかするか…(いや、後者だけでたぶん解決するけど、前者もあったほうがよさそうなので)。

まー、別に急がないので、しばらく待てば対応版のインストーラがリリースされるとは思うけどさ。

| | コメント (0) | トラックバック (1)

PC一台分。

Core i7導入に伴い、PCの部品が余りました。マザーボードとメモリ、CPUにHDD。

全部売り払うと、一万ちょいにはなる見込み。

ですが。
この他にPCケースを買えば、もう一台組み上がります(キーボードは予備があるし)。大体一万ちょいですかね。

さてと。
売り払って一万円を得るか、一万円を払ってもう一台のPCを得るか。問題です。

…どうもCore i7、挙動が怪しいところがあるというか、少なくともLinux導入には癖がありそうな気がするんだよなー。

Windowsマシンは分けておいた方が良い気もしてきた…。

| | コメント (0) | トラックバック (0)

次の試練。CentOSがインストールできない(汗)

起動不能問題は、メモリを刺し直したらあっさり解決しました。やれやれデス。

で、次の問題。
元々の目的が、職場で満足に勉強できないLinux+クラスタ(グリッド)を心行くまでいぢり倒す環境の確保、だったので、まずはCentOS 64bit版のインストールを、と思ったですよ。

以前Dual core Atomの機体にインストールテストしたときのPXEブート環境が残してあったので、こいつで起動。

…途中でpanic。
そういえば、Atomの時も出たなこれ。何か、グラフィックカードの認識に失敗している気配。しかし、Atomの時はオンボードグラフィックで逃げたけど、今回はそうも行かず。

仕方無いので、USBブートの準備をする。現状すぐに使えるマシンはDebianが入ったサーバなのだけど、小型機(てか、Sizka)なので工学ドライブが無いのでした。

今度は起動するものの、何かドライバ読み込んでいる最中に大量の謎文字を吐いてフリーズしたよ(--;

試しに、Debianのインストールを突っ込んでみる。Sarge直前の古い奴だけど、起動確認くらいはできるだろう。
起動はした…が、「CDをマウントできません」ってのは、マシンが悪いのかCDが悪いのか(汗)

どうも八方塞がりかつ情報量が少なすぎるので、ひとまずVistaのインストールを始めてます。

そしてこの記事は、DebianサーバにX WindowとFirefox、Cannaだけを追加して作業中…。

最近のWebサイトは、クロック500MHzの機体には非常に荷が重い、ということがよく分かりましたさ(--;

| | コメント (0) | トラックバック (0)

Core i7が動きません(爆)

はい、結局桜庭一樹よりCore i7を選んだ、ライトノベルファン失格なあたし(今回の桜庭一樹新刊はライトノベルぢゃない、という突っ込みは却下)。

で、結局。

  • Core i7 920
  • GIGABYTEのGA-EX58DS4
  • DDR3メモリ2GB×3=6GB(!というか笑)
  • あと、SATA HDDを250GB

という構成にて。とりあえず電源とか光学ドライブ、グラフィックボードとかは使いまわして、今のPentium D機体とさしかえようと。そして、今のCPUとマザーボードは、ソフマップキャンペーン15%買取で売りさばこうと。

…ソフマップ、キャンペーンチケット渡さない事件があったけどな(--;

さっそく昨日組み換えをやったのですが。

ディスプレイに何も映りません!!!

グラフィックボードが壊れたかと思い、Atomマザー用に確保していたPCIのボードに交換するも、症状は変わらず。てか、GPUのヒートシンクが冷たいので、通電していないような感じ。

CPUのほうは、ほんのり暖かいので通電している模様。

BEEP音のパターンから判定すると、「Power Error」

ドライブ類全部はずして、メモリも1枚刺し(2GB)にしても、症状変わらず。

ぶっとい500W電源咥えこんでまだ物足りないといいやがりますか、この娘っ子は?!

Core i7は省電力CPUって認識だったんだけどなー、おかしいなー、そもそも6GBメモリはやばかったかなー、と思いつつ、ぢゃぁどんだけ叩き込めば満足ですかお嬢さん?!、とGoogle先生に問い合わせてみると、肝心のマザーボードの資料に。

http://www.links.co.jp/faq/gigabyte-intel/gaex58ud5gaex58extremepost69bi.html

Q:
GA-EX58-UD5、GA-EX58-EXTREMEで、POSTコード 69を表示したままBIOSが起動しない。GA-EX58-DS4で画面表示されずBIOSが起動しない。

A:
メモリを青いスロットのみで使用している場合、この不具合が発生します。
メモリを白いスロットに変更し起動して下さい。
マザーの不具合ではなく、CPUに合わせた仕様となります。

あー。
あーー。
あーーーー。

これか…(--|||

マニュアルをよく見たら、白いほうからナンバリング1で始まってるよ…。
だって、青いほうが左端にあって、左からナンバリングされているんだもん!普通端から埋めるでしょ?!(泣)

さて、これから組みなおすか…。
あわてて1000W電源とか買いに行かなくて、正解だったよ…。

| | コメント (0) | トラックバック (0)